UKC Forums UKC Front Page :: Field Operations :: Show Operations :: Registration :: UKC Store
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Registration is free! Calendar Find other members Frequently Asked Questions Search Home  
UKC Forums : Powered by vBulletin version 2.3.0 UKC Forums > Departments > UKC Coonhounds > Alpha handheld problem
  Last Thread   Next Thread
Author
Thread Post New Thread    Post A Reply
Swamp Hunter
UKC Forum Member

Registered: Apr 2007
Location: St. Amant,LA
Posts: 127

Alpha handheld problem

My alpha handheld has quit working for some reason and I was hoping some of you Garmin gurus might have an answer. I canít get the handheld to turn on and the screen wonít come on when you plug it into the charger. Iíve been able to get it to come on after playing around with it and taking the battery out a few times, but once I turn it off and try to turn it back on again, it does the same thing. Iím not sure if the battery is done for or if it has a loose wire/connection. What are your thoughts?

Report this post to a moderator | IP: Logged

Old Post 05-19-2019 03:27 AM
Swamp Hunter is offline Click Here to See the Profile for Swamp Hunter Click here to Send Swamp Hunter a Private Message Find more posts by Swamp Hunter Add Swamp Hunter to your buddy list Edit/Delete Message Reply w/Quote
Cory Highfill
UKC Forum Member

Registered: Oct 2004
Location: Clarksville, AR
Posts: 916

I'd try a buddy's battery to eliminate that as a possibility. I'd also try another charger to make sure that's not it. Beyond that, Garmin will trade you a refurb unit ig you contact them. I'm not sure how much they charge, but I'm thinking it's a little over a hundred bucks. The procesd is easy and I've had good luck with the refurbished unit I got. Good luck!

Report this post to a moderator | IP: Logged

Old Post 05-19-2019 01:01 PM
Cory Highfill is offline Click Here to See the Profile for Cory Highfill Click here to Send Cory Highfill a Private Message Click Here to Email Cory Highfill Find more posts by Cory Highfill Add Cory Highfill to your buddy list Edit/Delete Message Reply w/Quote
lblhunter
UKC Forum Member

Registered: Sep 2018
Location: west ky
Posts: 39

Re: Alpha handheld problem

quote:
Originally posted by Swamp Hunter
My alpha handheld has quit working for some reason and I was hoping some of you Garmin gurus might have an answer. I canít get the handheld to turn on and the screen wonít come on when you plug it into the charger. Iíve been able to get it to come on after playing around with it and taking the battery out a few times, but once I turn it off and try to turn it back on again, it does the same thing. Iím not sure if the battery is done for or if it has a loose wire/connection. What are your thoughts?

If you can get it to come on can you push and release the on-off button to show the status of the battery?

Report this post to a moderator | IP: Logged

Old Post 05-20-2019 01:23 AM
lblhunter is offline Click Here to See the Profile for lblhunter Click here to Send lblhunter a Private Message Find more posts by lblhunter Add lblhunter to your buddy list Edit/Delete Message Reply w/Quote
joey
UKC Forum Member

Registered: Jun 2012
Location: McRae Ar
Posts: 3669

Take the battery out, plug the handheld in and then put the battery in. If it works let the battery charge.

__________________
Michael Rosamond
Sunspot Lights
936-827-6309
http://www.sunspotlights.com/
When brightness matters!!

Home Of:
PKC Ch, Grch Grnch 2008 Tx state champion They call me Crazy Betty

PKC SCh CH Grnch They call me Howler too

Report this post to a moderator | IP: Logged

Old Post 05-20-2019 01:28 AM
joey is offline Click Here to See the Profile for joey Click here to Send joey a Private Message Find more posts by joey Add joey to your buddy list Edit/Delete Message Reply w/Quote
Swamp Hunter
UKC Forum Member

Registered: Apr 2007
Location: St. Amant,LA
Posts: 127

The one time I was able to get the handheld to come on, the battery status showed 99% charged. I plugged it into the charger and left it for a few hours. When I returned, it still said 99%. I noticed a few times before the handheld stopped working, that it would never fully charge to 100%. Iím thinking the battery is bad. I did what Micheal proposed and it still didnít work. Iím going to try and swap out the batteries with another system and see if it works then. If it does, then it has to be the battery.

Report this post to a moderator | IP: Logged

Old Post 05-20-2019 10:16 PM
Swamp Hunter is offline Click Here to See the Profile for Swamp Hunter Click here to Send Swamp Hunter a Private Message Find more posts by Swamp Hunter Add Swamp Hunter to your buddy list Edit/Delete Message Reply w/Quote
All times are GMT. The time now is 09:02 PM. Post New Thread    Post A Reply
  Last Thread   Next Thread
Show Printable Version | Email this Page | Subscribe to this Thread


Forum Jump:
 

Forum Rules:
You may not post new threads
You may not post replies
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are ON
[IMG] code is ON
 
< Contact Us - The United Kennel Club >

Copyright 2003-2017, United Kennel Club
Powered by: vBulletin Version 2.3.0
(vBulletin courtesy Jelsoft Enterprises Limited.)